Fancybox 1.3.4 не работает с jQuery 1.9.0 и выше. Как исправить?

Ситуация: В проекте использовался jQuery 1.8.3 и Fancybox 1.3.4.

Проблема: Fancybox перестал работать после апдейта jQuery до версии 1.12.4. В консоли браузера была ошибка:

fancybox() is not a function  

Решение:

1) Выкачиваем fancybox по этой ссылке: fancybox.net/js/fancybox-1.3.4/jquery.fancybox-1.3.4.js

2) Открываем любым текстовым редактором и заменяем строку 25

isIE6 = $.browser.msie && $.browser.version < 7 && !window.XMLHttpRequest,

на следующую:

isIE6 = navigator.userAgent.match(/msie [6]/i) && !window.XMLHttpRequest,

А также заменяем на 617-ой строке это:

 $.browser.msie 

на это:


navigator.userAgent.match(/msie [6]/i)

3) Сохраняем на сервере, обновляем страницу с Ctrl+Shift+R.

Источник: https://stackoverflow.com/a/14344290/9448859

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *